Hello!

Inspiré(e) de prendre part à la discussion ? Ou de poser une question ou demander de l’aide ?

Alors bienvenues dans les grands sujets des forums de La Bulle : m’inscrire.

Cette partie du forum n’est pas compatible avec les bloqueurs publicitaires

Félicitations à vous, de préférer les accès payants plutôt que la gratuité par la publicité, c’est honnorable et cohérent de votre part. Malheureusement, l’accès payant par micropaiement (qui serait d’environ 1 cent pour 20 pages consultées) n’est pour l’instant pas encore mis en place, et l’accès gratuit sans publicité, est réservé aux membres actif(ve)s du forum. En attendant, si vous souhaitez poursuivre votre visite chez nous, vous pouvez ajouter le site à votre liste blanche, ou encore mieux, désactiver le bloqueur partout. Pour ajouter le site à votre liste blanche, pour Firefox (similaire pour les autres navigateurs), rendez‑vous en bas à gauche de la fenêtre de votre navigateur, et cliquez sur le menu comme dans l’exemple de l’image ci‑dessous, puis rechargez la page, en appuyant sur F5.

À propos des images disparues sur le forum
Auteur Message
Administrateur
Avatar de l’utilisateur
  • Genre : Télétubbie
  • Messages : 17497
Lun 1 Sep 2014 07:42
Message À propos des images disparues sur le forum
Zen disais dans Re: Petits exercices Photoshop :

zen a écrit : 
Lorsqu'une image a disparu, il y a un petit carré avec je ne sais plus quoi dedans à la place non ?
Si oui, tu n'as qu'à laisser ça comme ça, tout le monde comprendra.

Ça pose quand‑même au moins quatre problèmes.

Les problèmes


Les petits carrés qui ne sont pas si petits que ça, sont trop gros quand ils apparaissent à la place d’une image qui était utilisée comme un smiley. Pour ces cas là, je préférerais utiliser une petite image de substitution, et doit donc le faire moi‑même.

Les carrés qui s’affichent sont laids, et ça casse complétement un message quand l’image postée était jolie ou informative.

Les images manquantes, c’est un problème différent, pourtant comparable à celui des liens qui se terminent en « Erreur 404 — Page non‑trouvée », sauf que là, ce serait « image non‑trouvée ».

En plus d’être un problème comparable, c’est avec les hébergeurs d’images, souvent le problème en double, parce que avec le BBCode des images hébergées sur par exemple ImageShack, les images sont inclues dans un lien, et quand l’image a disparue, le lien est typiquement lui‑aussi cassé, et alors il y a une image disparue dans un lien brisé… un couac dans un couac Hahaha! .

Pourquoi ce sont des problèmes


Ces quatre problèmes sont ennuyeux non‑seulement pour les gens (y compris les anonymes non‑membres de passage), ils le sont aussi de l’appréciation des robots, genre ceux de Google, Blekko, Exalead, Bing et cie.

À ce propos, une chose que je trouve dommage sur le forum, c’est qu’il est beaucoup plus visité par des robots que par des humains [1], et je me demande si ce n’est pas un peu une conséquence de ce problème. Les moteurs de recherche ont en effet tendance à ne pas renvoyer les internautes vers des pages semblant défectueuses ou non‑fiables, et ces robots, roulent pour les moteurs de recherche. Alors je me demande si cette aberration d’avoir plus de visiteurs robots [2] que de visiteurs humains ne serait pas dut à ça. En marge et sur un autre sujet, c’est en partie pour cette raison que j’ai fait des éditions à la volée récemment.

Puis ce n’est pas que pour les robots, c’est pour les visiteur(se)s et les membres (même si peu nombreux Gêné(e) ) et futur(e)s membres. C’est mieux d’avoir des messages lisibles et pas de liens brisées ou images manquantes, pas seulement pour les robots, qui ne font que mettre en pratique une sélection selon ce qu’ils pensent être les attentes des internautes (souvent assez mal, mais pour des raisons qui n’ont rien à voir avec ces critères là, qui sont correctes et légitime). Bref, c’est pour les visiteurs humains, et seulement en second lieux pour les robots, et quand c’est pour les robots, c’est seulement en ce qu’ils s’en préoccupent pour les humains.

[1] Pour donner une idée, les robots lisent à eux‑seuls, chaque jour environ 3 000 à 4 000 pages sur le forum, tandis que les humains n’en lisent chaque jour que environ 200 à 300.

[2] Je ne parle pas des robots spammeurs, c’est un autre problème, et ils sont de plus en plus bloqués, à mesure que je complète la liste de blocage chaque fois qu’il en arrive un depuis une IP qui n’était pas connue.

Image
Hibou57

« La perversion de la cité commence par la fraude des mots » [Platon]
Profil Site Internet
Administrateur
Avatar de l’utilisateur
  • Genre : Télétubbie
  • Messages : 17497
Mar 2 Sep 2014 20:37
Message Re: À propos des images disparues sur le forum
J’avais oublié de dire que j’ai fait une sauvegarde de toutes les images liées depuis le forum. Je le referai périodiquement. Ça prend beaucoup de place, alors je ne les copierai pas toutes sur le forum, même si je les garde chez moi, ou alors il faudra que je les réduise ou compresse.

  • 742 images sont sur le forum, et donc en lieux sûr;
  • 5 588 images sont externes au forum;
  • Sur le nombre d’images externes, 2 258 sont portées disparues.

Ça en fait quand‑même 3 330 qui sont sauvées (et elles pèsent 336 MB en tout Oops, n’a fait une bêtise , alors je n’ose pas imaginer si elles étaient toutes là) et que je pourrai rétablir au cas où elles disparaitrait de là où elles sont.

Image
Hibou57

« La perversion de la cité commence par la fraude des mots » [Platon]
Profil Site Internet
Administrateur
Avatar de l’utilisateur
  • Genre : Télétubbie
  • Messages : 17497
Sam 6 Sep 2014 07:32
Message Re: À propos des images disparues sur le forum
Hibou a écrit : 
En plus d’être un problème comparable, c’est avec les hébergeurs d’images, souvent le problème en double, parce que avec le BBCode des images hébergées sur par exemple ImageShack, les images sont inclues dans un lien, et quand l’image a disparue, le lien est typiquement lui‑aussi cassé, et alors il y a une image disparue dans un lien brisé… un couac dans un couac Hahaha! .

Voilà, ça c’est résolu, au moins pour l’instant. Les liens qui enrobaient les images disparues ont été supprimés. Ça ne fait pas revenir les images, mais c’est déjà un dysfonctionnement en moins.

Par exemple là, les images manquantes restent telles‑quelles, mais elles ne font plus de liens : Re: Mes loisirs créatifs. Au contraire, là, les images ne sont pas manquantes, et les liens ont été laissés : Re: Petits exercices Photoshop.

Les liens de ce type, c’est à dire englobant une image, il y en avait 1 960 différents dans 1 985 messages (faut pas être surpris, c’est logique, certains liens étaient en plusieurs exemplaires, par exemple répétés dans des citations). Sur ce nombre, 868 liens ont été supprimés dans 919 messages (même remarques, c’est normal si le nombre de liens différents est plus petit que le nombre de messages).

Normalement il n’y a pas eu d’accidents, mais au cas où, il faut le dire, et j’ai une sauvegarde de ce matin à minuit.

Ric a raison, ServImg.com semble plus fiable que ImageShack.us… mais pour combien de temps ? Dis rien

Image
Hibou57

« La perversion de la cité commence par la fraude des mots » [Platon]
Profil Site Internet